[Mk4 Golf] Oem Xenon Wiring Adapters And Rheostat Mod - D.I.Y Guides and How to Instructions - uk-mkivs

Jump to content


Photo
Mk4 Golf

Oem Xenon Wiring Adapters And Rheostat Mod



  • Please log in to reply
196 replies to this topic

#1 old_n07

old_n07

    Diesel isn't a dirty word

  • Technical Contributor
  • PipPipPipPipPipPip
  • 11030 posts
  • North Staffs
  • **-----**

Posted 24 March 2009 - 06:23 AM

To install factory Xenon headlights into a car that did not come with xenons fitted you need a wiring adapter loom as the standard headlights use a 10 pin plug and the xenons use a 12 pin one.



There are really two options:
1. Buy a ready made loom from Kufatec but remember that postage is about €12
2. Make the loom from parts available from VW

To make the loom you will need the following parts:





































Quantity
Part Number
Description
2
1J0 973 835
T10 Male connector
5
000 979 134
1mm wire with male pins both ends
1
000 979 226
2.5mm wire with male pins both ends
2
1J0 941 165
T12 Female connector
4
000 979 131
1mm wire with female pins both ends
4
000 979 225
2.5mm wire with female pins both ends


To wire up the adapters you will need to cut each repair wire in half and solder it to the corresponding repair wire for each pin location, use heat shrink tubing to insulate the join, if the wire will be too long then adjust as necessary.



T10 End
T12 End
PIN
Repiar wire part number
Wire size
PIN
Repair wire part number
Wire size
1
000 979 134
1mm
1
000 979 131
1mm
2
Fog light - no connection on T12 for xenon
3
000 979 134
1mm
8
000 979 225
2.5mm
4
000 979 226
2.5mm
8
000 979 225
2.5mm
5
000 979 134
1mm
11
000 979 131
1mm
6
000 979 134
1mm
4
000 979 131
1mm
7
000 979 226
2.5mm
6
000 979 225
2.5mm
8
000 979 226
2.5mm
7
000 979 225
2.5mm
9
000 979 226
2.5mm
5
000 979 225
2.5mm
10
000 979 134
1mm
3
000 979 131
1mm

Rheostat mod

By default the xenons are designed to work with the auto leveling system on cars that have been factory fitted with xenon headlights. However it is possible to modify the wiring so they can be adjusted manually via the headlight height adjustment wheel on the dash.

This involves cutting two wires internally inside the lights and adding two wires to the adapter loom if you bought it from Kufatec, if you made the loom then the wires are already present. They are highlighted in red in the above wiring instructions.

Internal re-wiring on 03+ xenons.



INSIDE the headlight cut the yellow wire that comes from pin 11 of the 12 pin connector and goes to the ballast pack, cut the black wire that comes from the leveling motor connector and goes to the ballast. Join these two wires and insulate the connection and the cut ends of the other wires.

Be carefull NOT to cut the black wire from the leveling motor that goes to pin 1 of the 12 pin connector

The holes in the plugs will need sealing to prevent water ingress into the assembly, this can be done with silicone

Other threads discussing the adapters: 1- 2


#2 sean_vdub

sean_vdub

    Newbie

  • New Members
  • Pip
  • 4 posts

Posted 28 July 2009 - 07:44 AM

 Help needed, I understand the cutting of wires inside the headlight to enable the rheostat to work, but my adapters I have are from Kufatec...


Do I need to add two extra wires to my Kufatec adapters, of do I add three??


T10  Pin 1 = Level Motor Power (+)  -->    T12  Pin 1 = Level Motor Power (+)


T10  Pin 5 = Level Motor Control (+)  -->   T12 Pin 11 Level Motor Control (+)


BUT... do I need to add a wire from T10  Pin 3 which is Level Motor Power (-) and If so does it go to  T12  Pin 8 as there is already a wire into this pin in the Kufatec adapter????


Very confused.  Any help would be appreciated =) ?



#3 NooNoo

NooNoo

    NooNoo

  • Full Members
  • PipPipPipPipPip
  • 9366 posts
  • Leicester
  • Golf IV GTI 1.8T 20v AGU 150PS

Posted 27 October 2009 - 05:04 PM

Here are some pics of the internal wiring modification: -



The other side: -



Thought this might help.


[:)]


Golf 1.8T AGU | 232Bhp | Rtech | k03s | Blueflame turbo-back exhaust | K & N panel | SFS / Forge hoses | TurboRevs SMIC | VR6 Clutch | SMF | Saikou Michi catch can | Bilstein B14s | S3 upper & lower braces | Eibach 25mm ARBs | All SuperPro bushes | 312mm/256mm brakes | 18" BBS RCs | Rline rear | R32 front | Hoefle skirts | OEM Xenons | Retrofit heated seats | One touch demister | W8 Interior light | Sunroof | TT Hubs | TT wishbones | TT quick rack |


#4 NooNoo

NooNoo

    NooNoo

  • Full Members
  • PipPipPipPipPip
  • 9366 posts
  • Leicester
  • Golf IV GTI 1.8T 20v AGU 150PS

Posted 29 October 2009 - 03:47 PM

Hooked one up to test tonight. Fantastic!


Sheds more light and nice and white (6000k).


Rheostat working perfectly to [Y]


A big thank you [clap]


Golf 1.8T AGU | 232Bhp | Rtech | k03s | Blueflame turbo-back exhaust | K & N panel | SFS / Forge hoses | TurboRevs SMIC | VR6 Clutch | SMF | Saikou Michi catch can | Bilstein B14s | S3 upper & lower braces | Eibach 25mm ARBs | All SuperPro bushes | 312mm/256mm brakes | 18" BBS RCs | Rline rear | R32 front | Hoefle skirts | OEM Xenons | Retrofit heated seats | One touch demister | W8 Interior light | Sunroof | TT Hubs | TT wishbones | TT quick rack |


#5 MAH

MAH

    Just grazing

  • Full Members
  • PipPip
  • 485 posts

Posted 29 October 2009 - 03:55 PM

Good to hear its working mate!



#6 NooNoo

NooNoo

    NooNoo

  • Full Members
  • PipPipPipPipPip
  • 9366 posts
  • Leicester
  • Golf IV GTI 1.8T 20v AGU 150PS

Posted 29 October 2009 - 04:03 PM

Now after some white LED side lights before Saturday so I can get the Xenons fitted then.


I have the "blue" white ones in my current lights, but really think I need LEDs for these to get a better match.


[Y]


Golf 1.8T AGU | 232Bhp | Rtech | k03s | Blueflame turbo-back exhaust | K & N panel | SFS / Forge hoses | TurboRevs SMIC | VR6 Clutch | SMF | Saikou Michi catch can | Bilstein B14s | S3 upper & lower braces | Eibach 25mm ARBs | All SuperPro bushes | 312mm/256mm brakes | 18" BBS RCs | Rline rear | R32 front | Hoefle skirts | OEM Xenons | Retrofit heated seats | One touch demister | W8 Interior light | Sunroof | TT Hubs | TT wishbones | TT quick rack |


#7 richwig83

richwig83

    Chief Troll

  • Full Members
  • PipPipPipPipPipPip
  • 15985 posts
  • Golf V GTI Edition 30 2.0 230PS DSG

Posted 15 November 2009 - 03:10 AM

NooNoo... will the mod work with the mk5 xenons too?


 

brakessig.jpg
 

 

 


#8 NooNoo

NooNoo

    NooNoo

  • Full Members
  • PipPipPipPipPip
  • 9366 posts
  • Leicester
  • Golf IV GTI 1.8T 20v AGU 150PS

Posted 15 November 2009 - 11:22 AM

Sorry mate, I don't know. I just followed this guide for the mk4 ones.


You need a mk5 expert really. I see no reason why it shouldn't be possible though.


[:)]


Golf 1.8T AGU | 232Bhp | Rtech | k03s | Blueflame turbo-back exhaust | K & N panel | SFS / Forge hoses | TurboRevs SMIC | VR6 Clutch | SMF | Saikou Michi catch can | Bilstein B14s | S3 upper & lower braces | Eibach 25mm ARBs | All SuperPro bushes | 312mm/256mm brakes | 18" BBS RCs | Rline rear | R32 front | Hoefle skirts | OEM Xenons | Retrofit heated seats | One touch demister | W8 Interior light | Sunroof | TT Hubs | TT wishbones | TT quick rack |


#9 NooNoo

NooNoo

    NooNoo

  • Full Members
  • PipPipPipPipPip
  • 9366 posts
  • Leicester
  • Golf IV GTI 1.8T 20v AGU 150PS

Posted 24 November 2009 - 04:40 PM

 He are some pics of the modified Kufatec loom.


Light end: -



Car loom end: -



Connections.


Car end.                                 Light end.


1                     to                   1


5                     to                   11


Hope this helps.


Big thanks to Neil for his excellent guide.


[:)]


Golf 1.8T AGU | 232Bhp | Rtech | k03s | Blueflame turbo-back exhaust | K & N panel | SFS / Forge hoses | TurboRevs SMIC | VR6 Clutch | SMF | Saikou Michi catch can | Bilstein B14s | S3 upper & lower braces | Eibach 25mm ARBs | All SuperPro bushes | 312mm/256mm brakes | 18" BBS RCs | Rline rear | R32 front | Hoefle skirts | OEM Xenons | Retrofit heated seats | One touch demister | W8 Interior light | Sunroof | TT Hubs | TT wishbones | TT quick rack |


#10 richwig83

richwig83

    Chief Troll

  • Full Members
  • PipPipPipPipPipPip
  • 15985 posts
  • Golf V GTI Edition 30 2.0 230PS DSG

Posted 24 November 2009 - 04:44 PM

Ooooh that looks tidy! [Y]


Did you clock my bits and bobs i got for my xenons on my thread?


 

brakessig.jpg
 

 

 


#11 NooNoo

NooNoo

    NooNoo

  • Full Members
  • PipPipPipPipPip
  • 9366 posts
  • Leicester
  • Golf IV GTI 1.8T 20v AGU 150PS

Posted 24 November 2009 - 04:54 PM

Just looked. I presume it's proving difficult to get info on a mk5 rheostat mod?


It has to be possible. Somebody must have done it. With a wiring diagram it should be quite easy...


[:)]


Golf 1.8T AGU | 232Bhp | Rtech | k03s | Blueflame turbo-back exhaust | K & N panel | SFS / Forge hoses | TurboRevs SMIC | VR6 Clutch | SMF | Saikou Michi catch can | Bilstein B14s | S3 upper & lower braces | Eibach 25mm ARBs | All SuperPro bushes | 312mm/256mm brakes | 18" BBS RCs | Rline rear | R32 front | Hoefle skirts | OEM Xenons | Retrofit heated seats | One touch demister | W8 Interior light | Sunroof | TT Hubs | TT wishbones | TT quick rack |


#12 richwig83

richwig83

    Chief Troll

  • Full Members
  • PipPipPipPipPipPip
  • 15985 posts
  • Golf V GTI Edition 30 2.0 230PS DSG

Posted 24 November 2009 - 05:01 PM

Yeah... it seems that people dont mod mk5 golfs! [^o)]

I think it may be a brick wall tho if this info is accurate!!



I have the full wiring diagrams on another computer I can post them up later.  I retrofitted the full auto leveling system, its pretty straight forward more time consuming running the cables.  Its basically two level sensors and a control unit, using this method I also wired in the shutter cables so they work on high beam as Bi-Xenons should.

If you can get the parts off a crash damaged car I would recommend this route as the adjustment motors on the Xenons are feedback motors that report there position to the control unit via the extra wire so can't be wired to run off the leveller switch (people have tried and fried the motor), I thought about putting the halogen motor in however it is very tight through the access whole.  

Ohh well... looks like ill just adjust them and leave them alone!


 

brakessig.jpg
 

 

 


#13 NooNoo

NooNoo

    NooNoo

  • Full Members
  • PipPipPipPipPip
  • 9366 posts
  • Leicester
  • Golf IV GTI 1.8T 20v AGU 150PS

Posted 24 November 2009 - 05:07 PM

Hmmm, blimey didn't realise they have got so advanced. Looks like a PITA to be honest.


As you said just run unadjustable. Shame though.


Sorry I can't help.


[:)]


Edit: So no full beam for you?


Golf 1.8T AGU | 232Bhp | Rtech | k03s | Blueflame turbo-back exhaust | K & N panel | SFS / Forge hoses | TurboRevs SMIC | VR6 Clutch | SMF | Saikou Michi catch can | Bilstein B14s | S3 upper & lower braces | Eibach 25mm ARBs | All SuperPro bushes | 312mm/256mm brakes | 18" BBS RCs | Rline rear | R32 front | Hoefle skirts | OEM Xenons | Retrofit heated seats | One touch demister | W8 Interior light | Sunroof | TT Hubs | TT wishbones | TT quick rack |


#14 richwig83

richwig83

    Chief Troll

  • Full Members
  • PipPipPipPipPipPip
  • 15985 posts
  • Golf V GTI Edition 30 2.0 230PS DSG

Posted 24 November 2009 - 05:13 PM

Not sure mate.... ill run them without to start then i might feed the wires up when i can be arsed!!!


 

brakessig.jpg
 

 

 


#15 AaronGS

AaronGS

    Just grazing

  • Full Members
  • PipPip
  • 934 posts

Posted 08 December 2009 - 02:11 PM

Quick question - on the Mk4 post '03 xenons is it okay to unscrew the ballast from the inside of the cover? I cannot insulate one of the cut wires[:$]  at the moment.


 



#16 NooNoo

NooNoo

    NooNoo

  • Full Members
  • PipPipPipPipPip
  • 9366 posts
  • Leicester
  • Golf IV GTI 1.8T 20v AGU 150PS

Posted 08 December 2009 - 02:33 PM

Yes it's ok. I removed mine also, just to "park" the insulated cut wires neatly. Just make a mental note of the bracket fitment.


[:)]


Golf 1.8T AGU | 232Bhp | Rtech | k03s | Blueflame turbo-back exhaust | K & N panel | SFS / Forge hoses | TurboRevs SMIC | VR6 Clutch | SMF | Saikou Michi catch can | Bilstein B14s | S3 upper & lower braces | Eibach 25mm ARBs | All SuperPro bushes | 312mm/256mm brakes | 18" BBS RCs | Rline rear | R32 front | Hoefle skirts | OEM Xenons | Retrofit heated seats | One touch demister | W8 Interior light | Sunroof | TT Hubs | TT wishbones | TT quick rack |


#17 AaronGS

AaronGS

    Just grazing

  • Full Members
  • PipPip
  • 934 posts

Posted 08 December 2009 - 02:57 PM

NooNoo, cheers for that. All done now and cut ends also similarly parked!


Cheers.



#18 MAH

MAH

    Just grazing

  • Full Members
  • PipPip
  • 485 posts

Posted 10 December 2009 - 09:15 AM

Well, would you need to insulate the wires that have been cut as im assuming that there is no power going through them.


p.s. Im not referring to the ones that have been joint for the levelling to work.



#19 AaronGS

AaronGS

    Just grazing

  • Full Members
  • PipPip
  • 934 posts

Posted 10 December 2009 - 11:43 AM

Um, there is still power isn't there? I may be well wrong but I insulated mine to be sure


 



#20 MAH

MAH

    Just grazing

  • Full Members
  • PipPip
  • 485 posts

Posted 10 December 2009 - 04:03 PM

Also, does it usually take a few seconds for the xenons to light up? My driver side xenon usually lights up later than the left.


Sometimes, the right side does not come on at all straight after i start up the car. I have to turn the lights off and then on to get it to work.


Is this normal?



#21 NooNoo

NooNoo

    NooNoo

  • Full Members
  • PipPipPipPipPip
  • 9366 posts
  • Leicester
  • Golf IV GTI 1.8T 20v AGU 150PS

Posted 10 December 2009 - 05:16 PM

Hi Mah.


No it's not normal. Mine light simultaneously but then get brighter over a period of about 5 seconds.


[:)]


Golf 1.8T AGU | 232Bhp | Rtech | k03s | Blueflame turbo-back exhaust | K & N panel | SFS / Forge hoses | TurboRevs SMIC | VR6 Clutch | SMF | Saikou Michi catch can | Bilstein B14s | S3 upper & lower braces | Eibach 25mm ARBs | All SuperPro bushes | 312mm/256mm brakes | 18" BBS RCs | Rline rear | R32 front | Hoefle skirts | OEM Xenons | Retrofit heated seats | One touch demister | W8 Interior light | Sunroof | TT Hubs | TT wishbones | TT quick rack |


#22 MAH

MAH

    Just grazing

  • Full Members
  • PipPip
  • 485 posts

Posted 10 December 2009 - 05:36 PM

What could be causing this? What should i check?



#23 NooNoo

NooNoo

    NooNoo

  • Full Members
  • PipPipPipPipPip
  • 9366 posts
  • Leicester
  • Golf IV GTI 1.8T 20v AGU 150PS

Posted 10 December 2009 - 05:43 PM

Well, I'm not sure to be honest. There are only two modules though really, the ballast itself and the internal high voltage module.


So I'm guessing it's one of those [:S]


You could try elimination but that would require both lights to be off the car.


I powered my xenons from an old leisure battery before fitting them, just to make sure they were working.


Mine strike instantly.


[:)]


Golf 1.8T AGU | 232Bhp | Rtech | k03s | Blueflame turbo-back exhaust | K & N panel | SFS / Forge hoses | TurboRevs SMIC | VR6 Clutch | SMF | Saikou Michi catch can | Bilstein B14s | S3 upper & lower braces | Eibach 25mm ARBs | All SuperPro bushes | 312mm/256mm brakes | 18" BBS RCs | Rline rear | R32 front | Hoefle skirts | OEM Xenons | Retrofit heated seats | One touch demister | W8 Interior light | Sunroof | TT Hubs | TT wishbones | TT quick rack |


#24 old_n07

old_n07

    Diesel isn't a dirty word

  • Technical Contributor
  • PipPipPipPipPipPip
  • 11030 posts
  • North Staffs
  • **-----**

Posted 11 December 2009 - 01:30 AM

 As said, it can only be a couple of things - ballast or bulb generally, the easiest way to see which one is causing it is to swap the ballasts over and see if the problem swaps sides with it. If it does then the ballast its the problem and if it doesn't it may be the bulb so swap them over - if it is still the same side not working after swaping both the bulb and ballast over then it is the ignitor that is faulty [:(].


Neil



#25 MAH

MAH

    Just grazing

  • Full Members
  • PipPip
  • 485 posts

Posted 11 December 2009 - 04:56 AM

Woke up this morning and the driver siIde wont power up at all now. dont think its the bulb because there new, appart from switchiNg the ballast around, how else can i check them? Also, how would i test the ignitor?



#26 MAH

MAH

    Just grazing

  • Full Members
  • PipPip
  • 485 posts

Posted 11 December 2009 - 04:21 PM

 ?



#27 MAH

MAH

    Just grazing

  • Full Members
  • PipPip
  • 485 posts

Posted 14 December 2009 - 02:01 PM

Got an update guys, put my lights on and this time the right one started working and the left stopped (the right one wasnt working for a good 4 days and the left side was). After about half an hour, switched the lights off and then on and they both light up. Dont understand what could cause this


The headlights playing with my head [brick]



#28 NooNoo

NooNoo

    NooNoo

  • Full Members
  • PipPipPipPipPip
  • 9366 posts
  • Leicester
  • Golf IV GTI 1.8T 20v AGU 150PS

Posted 14 December 2009 - 02:11 PM

I would take them off and refit your standard lights.


Then you can swap the ballasts, ignitors and bulbs over at leisure and find out the cause.


I know it's not what you wanted to hear but I think you have limited options.


[:)


Golf 1.8T AGU | 232Bhp | Rtech | k03s | Blueflame turbo-back exhaust | K & N panel | SFS / Forge hoses | TurboRevs SMIC | VR6 Clutch | SMF | Saikou Michi catch can | Bilstein B14s | S3 upper & lower braces | Eibach 25mm ARBs | All SuperPro bushes | 312mm/256mm brakes | 18" BBS RCs | Rline rear | R32 front | Hoefle skirts | OEM Xenons | Retrofit heated seats | One touch demister | W8 Interior light | Sunroof | TT Hubs | TT wishbones | TT quick rack |


#29 MAH

MAH

    Just grazing

  • Full Members
  • PipPip
  • 485 posts

Posted 14 December 2009 - 02:31 PM

Yea i was considering that. If i get some time on sunday, I'll take the headlights off and check what the problem is.


What i dont understand is why each side of the headlight decides to randomly stop working for a few days and then start working?


Currently, both lights are working so im just hoping they dont start playing up again


p.s. im currently using aftermarket 6000k bulbs instead of the OEM ones, could this be causing the problem? Or the rheostat mod could that be affecting the headlights?



#30 NooNoo

NooNoo

    NooNoo

  • Full Members
  • PipPipPipPipPip
  • 9366 posts
  • Leicester
  • Golf IV GTI 1.8T 20v AGU 150PS

Posted 14 December 2009 - 05:50 PM

I very much doubt it's the 6000k bulbs, I'm using them (ebay £23) and they are fine on my setup.


I am going to buy some 4300k though (ebay again) as I find the 6000k extremely poor in bad weather and under street lighting.


The rheostat wiring should have no influence whatsoever on the light function.


I really can only think it's dodgy ballasts or ignitors.


[:)]


Golf 1.8T AGU | 232Bhp | Rtech | k03s | Blueflame turbo-back exhaust | K & N panel | SFS / Forge hoses | TurboRevs SMIC | VR6 Clutch | SMF | Saikou Michi catch can | Bilstein B14s | S3 upper & lower braces | Eibach 25mm ARBs | All SuperPro bushes | 312mm/256mm brakes | 18" BBS RCs | Rline rear | R32 front | Hoefle skirts | OEM Xenons | Retrofit heated seats | One touch demister | W8 Interior light | Sunroof | TT Hubs | TT wishbones | TT quick rack |






Also tagged with one or more of these keywords: Mk4 Golf


uk-mkivs.net is an independent Volkswagen enthusiast website owned and operated by VerticalScope Inc. Content on uk-mkivs.net is generated by its users. uk-mkivs.net is not in any way affiliated with Volkswagen AG.